postcrafter.de zeigt php-Code??

Hier könnt ihr Vorschläge anbringen, Bugs melden oder Fragen stellen, die das Forum betreffen.

postcrafter.de zeigt php-Code??

Beitragvon ilouHD » Mo 19. Jan 2015, 13:53

Hallo zusammen,

anscheinend gibt es einen Fehler auf http://postcrafter.de/

Wenn ich diese Seite aufrufe (Favorit) kommt das hier:
Code: Alles auswählen
  1. <?php
  2. /**
  3. *
  4. * @package phpBB3
  5. * @version $Id$
  6. * @copyright (c) 2005 phpBB Group
  7. * @license http://opensource.org/licenses/gpl-license.php GNU Public License
  8. *
  9. */
  10. include ('adsense.php');
  11. /**
  12. */
  13. /**
  14. * @ignore
  15. */
  16. define('IN_PHPBB', true);
  17. $phpbb_root_path = (defined('PHPBB_ROOT_PATH')) ? PHPBB_ROOT_PATH : './';
  18. $phpEx = substr(strrchr(__FILE__, '.'), 1);
  19. include($phpbb_root_path . 'common.' . $phpEx);
  20. include($phpbb_root_path . 'includes/functions_display.' . $phpEx);
  21. // Start session management
  22. $user->session_begin();
  23. $auth->acl($user->data);
  24. $user->setup('viewforum');
  25. display_forums('', $config['load_moderators']);
  26. // Set some stats, get posts count from forums data if we... hum... retrieve all forums data
  27. $total_posts   = $config['num_posts'];
  28. $total_topics   = $config['num_topics'];
  29. $total_users   = $config['num_users'];
  30. $l_total_user_s = ($total_users == 0) ? 'TOTAL_USERS_ZERO' : 'TOTAL_USERS_OTHER';
  31. $l_total_post_s = ($total_posts == 0) ? 'TOTAL_POSTS_ZERO' : 'TOTAL_POSTS_OTHER';
  32. $l_total_topic_s = ($total_topics == 0) ? 'TOTAL_TOPICS_ZERO' : 'TOTAL_TOPICS_OTHER';
  33. // Grab group details for legend display
  34. if ($auth->acl_gets('a_group', 'a_groupadd', 'a_groupdel'))
  35. {
  36.    $sql = 'SELECT group_id, group_name, group_colour, group_type
  37.       FROM ' . GROUPS_TABLE . '
  38.       WHERE group_legend = 1
  39.       ORDER BY group_name ASC';
  40. }
  41. else
  42. {
  43.    $sql = 'SELECT g.group_id, g.group_name, g.group_colour, g.group_type
  44.       FROM ' . GROUPS_TABLE . ' g
  45.       LEFT JOIN ' . USER_GROUP_TABLE . ' ug
  46.          ON (
  47.             g.group_id = ug.group_id
  48.             AND ug.user_id = ' . $user->data['user_id'] . '
  49.             AND ug.user_pending = 0
  50.          )
  51.       WHERE g.group_legend = 1
  52.          AND (g.group_type <> ' . GROUP_HIDDEN . ' OR ug.user_id = ' . $user->data['user_id'] . ')
  53.       ORDER BY g.group_name ASC';
  54. }
  55. $result = $db->sql_query($sql);
  56. $legend = array();
  57. while ($row = $db->sql_fetchrow($result))
  58. {
  59.    $colour_text = ($row['group_colour']) ? ' style="color:#' . $row['group_colour'] . '"' : '';
  60.    $group_name = ($row['group_type'] == GROUP_SPECIAL) ? $user->lang['G_' . $row['group_name']] : $row['group_name'];
  61.    if ($row['group_name'] == 'BOTS' || ($user->data['user_id'] != ANONYMOUS && !$auth->acl_get('u_viewprofile')))
  62.    {
  63.       $legend[] = '<span' . $colour_text . '>' . $group_name . '</span>';
  64.    }
  65.    else
  66.    {
  67.       $legend[] = '<a' . $colour_text . ' href="' . append_sid("{$phpbb_root_path}memberlist.$phpEx", 'mode=group&amp;g=' . $row['group_id']) . '">' . $group_name . '</a>';
  68.    }
  69. }
  70. $db->sql_freeresult($result);
  71. $legend = implode(', ', $legend);
  72. // Generate birthday list if required ...
  73. $birthday_list = '';
  74. if ($config['load_birthdays'] && $config['allow_birthdays'] && $auth->acl_gets('u_viewprofile', 'a_user', 'a_useradd', 'a_userdel'))
  75. {
  76.    $now = phpbb_gmgetdate(time() + $user->timezone + $user->dst);
  77.    // Display birthdays of 29th february on 28th february in non-leap-years
  78.    $leap_year_birthdays = '';
  79.    if ($now['mday'] == 28 && $now['mon'] == 2 && !$user->format_date(time(), 'L'))
  80.    {
  81.       $leap_year_birthdays = " OR u.user_birthday LIKE '" . $db->sql_escape(sprintf('%2d-%2d-', 29, 2)) . "%'";
  82.    }
  83.    $sql = 'SELECT u.user_id, u.username, u.user_colour, u.user_birthday
  84.       FROM ' . USERS_TABLE . ' u
  85.       LEFT JOIN ' . BANLIST_TABLE . " b ON (u.user_id = b.ban_userid)
  86.       WHERE (b.ban_id IS NULL
  87.          OR b.ban_exclude = 1)
  88.          AND (u.user_birthday LIKE '" . $db->sql_escape(sprintf('%2d-%2d-', $now['mday'], $now['mon'])) . "%' $leap_year_birthdays)
  89.          AND u.user_type IN (" . USER_NORMAL . ', ' . USER_FOUNDER . ')';
  90.    $result = $db->sql_query($sql);
  91.    while ($row = $db->sql_fetchrow($result))
  92.    {
  93.       $birthday_list .= (($birthday_list != '') ? ', ' : '') . get_username_string('full', $row['user_id'], $row['username'], $row['user_colour']);
  94.       if ($age = (int) substr($row['user_birthday'], -4))
  95.       {
  96.          $birthday_list .= ' (' . max(0, $now['year'] - $age) . ')';
  97.       }
  98.    }
  99.    $db->sql_freeresult($result);
  100. }
  101. // Assign index specific vars
  102. $template->assign_vars(array(
  103.    'TOTAL_POSTS'   => sprintf($user->lang[$l_total_post_s], $total_posts),
  104.    'TOTAL_TOPICS'   => sprintf($user->lang[$l_total_topic_s], $total_topics),
  105.    'TOTAL_USERS'   => sprintf($user->lang[$l_total_user_s], $total_users),
  106.    'NEWEST_USER'   => sprintf($user->lang['NEWEST_USER'], get_username_string('full', $config['newest_user_id'], $config['newest_username'], $config['newest_user_colour'])),
  107.    'LEGEND'      => $legend,
  108.    'BIRTHDAY_LIST'   => $birthday_list,
  109.    'FORUM_IMG'            => $user->img('forum_read', 'NO_UNREAD_POSTS'),
  110.    'FORUM_UNREAD_IMG'         => $user->img('forum_unread', 'UNREAD_POSTS'),
  111.    'FORUM_LOCKED_IMG'      => $user->img('forum_read_locked', 'NO_UNREAD_POSTS_LOCKED'),
  112.    'FORUM_UNREAD_LOCKED_IMG'   => $user->img('forum_unread_locked', 'UNREAD_POSTS_LOCKED'),
  113.    'S_LOGIN_ACTION'         => append_sid("{$phpbb_root_path}ucp.$phpEx", 'mode=login'),
  114.    'S_DISPLAY_BIRTHDAY_LIST'   => ($config['load_birthdays']) ? true : false,
  115.    'U_MARK_FORUMS'      => ($user->data['is_registered'] || $config['load_anon_lastread']) ? append_sid("{$phpbb_root_path}index.$phpEx", 'hash=' . generate_link_hash('global') . '&amp;mark=forums') : '',
  116.    'U_MCP'            => ($auth->acl_get('m_') || $auth->acl_getf_global('m_')) ? append_sid("{$phpbb_root_path}mcp.$phpEx", 'i=main&amp;mode=front', true, $user->session_id) : '')
  117. );
  118. // Output page
  119. page_header($user->lang['INDEX']);
  120. $template->set_filenames(array(
  121.    'body' => 'index_body.html')
  122. );
  123. page_footer();
  124. include ('analytics.php');
  125. ?>


Wie man sieht, wird php-Code angezeigt und nicht die Webseite an sich. Screenshot kann ich gerade nicht machen, da man da nicht viel erkennen würde (720p).

Wollte nur mal drauf hinweisen.

Mit freundlichen Grüßen,
ilouHD

PS: Bei index.php wird alles ganz normal geladen

//EDIT: Hier ist doch noch ein Screenshot: http://mivcon.net/other/Screeni.png
Bild
Benutzeravatar
ilouHD
 
Beiträge: 1733
Registriert: Do 9. Jan 2014, 14:49

Re: postcrafter.de zeigt php-Code??

Beitragvon Ch4t4r » Mo 19. Jan 2015, 15:12

Das war gestern auf allen seiten so..
Benutzeravatar
Ch4t4r
 
Beiträge: 455
Registriert: So 7. Jul 2013, 12:44

Re: postcrafter.de zeigt php-Code??

Beitragvon PostCrafter » Mo 19. Jan 2015, 15:44

Gestern war aus unerfindlichen Gründen php nicht mehr installiert, wodurch natürlich auch das Forum und alles was damit zusammen hängt nicht mehr funktioniert hat.

Tritt der Fehler bei dir immer noch auf, oder ist das nur ein Hinweis auf das Problem von gestern?
TeamSpeak-Server zur freien Nutzung: postcrafter.de
Benutzeravatar
PostCrafter
Administrator
 
Beiträge: 1443
Registriert: Do 6. Jun 2013, 19:16
Wohnort: Ebersberg

Re: postcrafter.de zeigt php-Code??

Beitragvon ilouHD » Mo 19. Jan 2015, 16:26

PostCrafter hat geschrieben:Gestern war aus unerfindlichen Gründen php nicht mehr installiert, wodurch natürlich auch das Forum und alles was damit zusammen hängt nicht mehr funktioniert hat.

Tritt der Fehler bei dir immer noch auf, oder ist das nur ein Hinweis auf das Problem von gestern?

Gerade am Handy ist er noch immer. Nach einem neu laden der Seite geht es aber normal
Bild
Benutzeravatar
ilouHD
 
Beiträge: 1733
Registriert: Do 9. Jan 2014, 14:49

Re: postcrafter.de zeigt php-Code??

Beitragvon ilouHD » Di 20. Jan 2015, 16:34

Ich wollte nur noch mal sagen, dass bei mir postcrafter.de noch immer nicht geht, sondern nur postcrafter.de/index.php
Bild
Benutzeravatar
ilouHD
 
Beiträge: 1733
Registriert: Do 9. Jan 2014, 14:49

Re: postcrafter.de zeigt php-Code??

Beitragvon Sep2703 » Di 20. Jan 2015, 16:37

Genau das Problem habe ich auch!

Die index.php kann ich ebenfalls nicht aufrufe. Bei posting.php oder viewtopic.php treten diese Probleme nicht auf.
Du möchtest programmieren lernen oder dein Bukkit-/Spigot-Wissen erweitern?
Hier habe ich für dich kostenlose Tutorials: https://youtube.com/janhektor
Benutzeravatar
Sep2703
 
Beiträge: 677
Registriert: Mi 8. Jan 2014, 15:13
Wohnort: 127.0.0.1

Re: postcrafter.de zeigt php-Code??

Beitragvon Twister_21 » Di 20. Jan 2015, 16:41

Bei mir hat es, nachdem PostCrafter PhP wieder installiert hat und ich meinen Browsercache geleert habe wieder funktioniert.
Mit freundlichen Grüßen
Twister21
Benutzeravatar
Twister_21
 
Beiträge: 652
Registriert: Mi 11. Jun 2014, 05:51
Wohnort: Deutschland

Re: postcrafter.de zeigt php-Code??

Beitragvon ilouHD » Di 20. Jan 2015, 16:42

Twister_21 hat geschrieben:Bei mir hat es, nachdem PostCrafter PhP wieder installiert hat und ich meinen Browsercache geleert habe wieder funktioniert.


Danke für den Tipp auf Skype. Browsercache leeren hat bei mir das Problem gelöst.
Bild
Benutzeravatar
ilouHD
 
Beiträge: 1733
Registriert: Do 9. Jan 2014, 14:49


Zurück zu Vorschläge, Bugs und Fragen

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste