Diskussion zu Bukkit 1.8

Anlaufstelle für Diskussionen über Minecraft und zugehörige Themen.

Diskussion zu Bukkit 1.8

Beitragvon ilouHD » Di 2. Sep 2014, 13:09

-Deleted-1 hat geschrieben:Kleiner Edit:

Daher heute die erste Craftbukkit 1.8 herauskam, sah sich, dass die nun wieder eine Array zurück gibt, also so wie früher.


Die CraftBukkit 1.8 habe ich auch schon xD, aber da funktioniert nichts :(
Bild
Benutzeravatar
ilouHD
 
Beiträge: 1733
Registriert: Do 9. Jan 2014, 14:49

Re: Bukkit.getOnlinePlayers() - deprecated

Beitragvon Twister_21 » Di 2. Sep 2014, 14:18

Es sieht aber irgendwie danach aus, dass Hive schon geupdatet wird, da sind ja schon seit heute früh Wartungsarbeiten und GommeHD.net hat getwittert, dass die auch Updaten wollen, man dann aber trotzdem mit der 1.7 Version spielen kann.

Edit: Um 16:00 Uhr wird geupdated.
Mit freundlichen Grüßen
Twister21
Benutzeravatar
Twister_21
 
Beiträge: 652
Registriert: Mi 11. Jun 2014, 05:51
Wohnort: Deutschland

Re: Bukkit.getOnlinePlayers() - deprecated

Beitragvon ilouHD » Di 2. Sep 2014, 14:46

Twister_21 hat geschrieben:Es sieht aber irgendwie danach aus, dass Hive schon geupdatet wird, da sind ja schon seit heute früh Wartungsarbeiten und GommeHD.net hat getwittert, dass die auch Updaten wollen, man dann aber trotzdem mit der 1.7 Version spielen kann.

Edit: Um 16:00 Uhr wird geupdated.


Das Updaten wird aber scheiße sein - habe eben mal bei mir die 1.8 rein gemacht und die ist TOTAL VERBUGGT. Ausserdem funktionieren meine Plugins damit nicht, die ich davor auf die 1.8 updaten wollte, aber die Imports nicht genommen wurden :(
Bild
Benutzeravatar
ilouHD
 
Beiträge: 1733
Registriert: Do 9. Jan 2014, 14:49

Re: Bukkit.getOnlinePlayers() - deprecated

Beitragvon Twister_21 » Di 2. Sep 2014, 15:00

Ja, ich hab auch gesehen, dass die craftbukkit.jar nichtmal zur hälfte fertig ist. Hive updated ja aber warscheinlich auch schon, aber ich glaube irgendwie nicht, dass die wirklich die Development-Build nehmen. GommeHD.net hat ja auch gesagt, dass man mit 1.7 dann immer noch joinen kann und auch sollte.
Zuletzt geändert von Twister_21 am Di 2. Sep 2014, 19:06, insgesamt 1-mal geändert.
Mit freundlichen Grüßen
Twister21
Benutzeravatar
Twister_21
 
Beiträge: 652
Registriert: Mi 11. Jun 2014, 05:51
Wohnort: Deutschland

Re: Diskussion zu Bukkit 1.8

Beitragvon Twister_21 » Di 2. Sep 2014, 15:41

Ok, ich glaube die haben noch nicht direkt auf 1.8 geupdated, sondern nur den Server 1.8 kompatibel gemacht. Jetzt können 1.7 und 1.8 joinen. Aber 1.8 Features gibt es noch nicht.
Zuletzt geändert von Twister_21 am Di 2. Sep 2014, 19:05, insgesamt 1-mal geändert.
Mit freundlichen Grüßen
Twister21
Benutzeravatar
Twister_21
 
Beiträge: 652
Registriert: Mi 11. Jun 2014, 05:51
Wohnort: Deutschland

Re: Diskussion zu Bukkit 1.8

Beitragvon theEvilReaper » Di 2. Sep 2014, 16:13

Twister_21 hat geschrieben:Ok, ich glaube die haben noch nicht direkt auf 1.8 geupdated, sondern nur den Server 1.8 ko+patibel gemacht. Jetzt können 1.7 und 1.8 joinen. Aber 1.8 Features gibt es noch nicht.


Naja ich hatte mir schon sowas gedacht das dabei etwas schräges raus kommt wenn Mojang die Bukkit jetzt weiter entwickelt. Ich hoffe mal ihr habt davon gehört. Jetzt heißt es abwarten was Mojang raus haut. Sonst müsst ihr halt warten bis Spigot eine Version raus gebracht hat.

Lg theEvilReaper
Bild
Benutzeravatar
theEvilReaper
 
Beiträge: 162
Registriert: Di 12. Nov 2013, 20:15

Re: Diskussion zu Bukkit 1.8

Beitragvon ilouHD » Di 2. Sep 2014, 17:11

Wie werden Listener nun registriert und wie funktioniert das mit dem @EventHandler in der 1.8?
Bild
Benutzeravatar
ilouHD
 
Beiträge: 1733
Registriert: Do 9. Jan 2014, 14:49

Re: Diskussion zu Bukkit 1.8

Beitragvon theEvilReaper » Di 2. Sep 2014, 20:19

marcsven hat geschrieben:Wie werden Listener nun registriert und wie funktioniert das mit dem @EventHandler in der 1.8?


Hey, ich habe mal etwas experimentiert und ne lösung gefunden wie man events registert. Doch vorerst die 1.8 die es immoment gibt is eigentlich keine 1.8 da sie nur dem Server vorgauckelt das der Server 1.8 ist damit die Clients joinen können es ist eigentlich nur eine 1.7.10 version die Mojang raus gebracht hat aber halt so das die 1.8 Spieler joinen können.

Bsp:

Code: Alles auswählen
  1. @Override
  2.    public void onEnable() {
  3.       Bukkit.getServer().getPluginManager().registerEvent(Type.ENTITY_DEATH, new TestListener(), Priority.Highest, this);
  4.       
  5.    }
  6.    


Jetzt denkt sich einer WTF was ist das?? Ich fange mal an etwas zu erklären

Wenn man jetzt Events registern wil muss man beim ersten Wert den er haben möchte den Type vom Event angeben, beim 2ten kommt der name vom Listener rein, 3tes ist die Priority ob es halt wichtig ist oder unwichtig und beim letzten kommt wie gewohnt einfach nur ein this hin. Damit wäre der Listener registert.

Ich editiere später den beitrag wie man das mit dem neuen listener nun alles macht muss docs lesen.

lg theEvilReaper
Bild
Benutzeravatar
theEvilReaper
 
Beiträge: 162
Registriert: Di 12. Nov 2013, 20:15

Re: Diskussion zu Bukkit 1.8

Beitragvon ilouHD » Di 2. Sep 2014, 21:31

Ja genau. WTF! Könntest du das botte noch mal genauer mit dem 1. Argument erklären, also diesem Type. Ist das die Methode in einer Klasse oder was genau ist das? Das habe ich noch nicht so richtig verstanden. Danke.
Bild
Benutzeravatar
ilouHD
 
Beiträge: 1733
Registriert: Do 9. Jan 2014, 14:49

Re: Diskussion zu Bukkit 1.8

Beitragvon PostCrafter » Di 2. Sep 2014, 21:40

Ich bin gerade ziemlich erstaunt, so etwas ähnliches gab es meiner Erinnerung nach schon einmal, wurde dann jedoch ziemlich schnell wieder verworfen.
TeamSpeak-Server zur freien Nutzung: postcrafter.de
Benutzeravatar
PostCrafter
Administrator
 
Beiträge: 1443
Registriert: Do 6. Jun 2013, 19:16
Wohnort: Ebersberg

Nächste

Zurück zu Minecraft

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast